<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<head>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="amphtml" href="https://celebrityinsider.org/amp/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/">
<meta name="p:domain_verify" content="eb3eaa384c05d7c451fa2a546258488f" />
<meta name="author" content="Dylan Fisher">
<meta name="news_keywords" content="drake, rihanna, " />
<meta name="keywords" content="celebrity news, drake, rihanna, " />
<title>Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason | Celebrity Insider</title>
<style id="reCAPTCHA-style">.google-recaptcha-container{display:block;clear:both;}</style>

<link rel="canonical" href="https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/" />
<meta name="description" content="The people, who have been hounding Rihanna for a new album, might get their wish sooner than later. The diva recently revealed that she had been" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason" />
<meta property="og:description" content="The people, who have been hounding Rihanna for a new album, might get their wish sooner than later. The diva recently revealed that she had been" />
<meta property="og:url" content="https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/" />
<meta property="og:image" content="https://celebrityinsider.org/wp-content/uploads/2020/04/Rihanna-New-Album-Coming-Soon.jpg" />
<meta property="article:published_time" content="2020-04-07" />
<meta property="article:modified_time" content="2020-04-07" />
<meta property="article:author" content="https://celebrityinsider.org/author/dylanfisher/" />
<meta property="article:section" content="Entertainment" />
<meta property="article:tag" content="drake" />
<meta property="article:tag" content="rihanna" />
<meta property="og:site_name" content="Breaking Celebrity News, Entertainment News, and Celebrity Gossip - Celebrity Insider " />
<meta property="fb:app_id" content="1646073299040160" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@CelebInsiderorg" />
<meta name="twitter:site" content="@CelebInsiderorg" />

<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Celebrity Insider &raquo; Feed" href="https://celebrityinsider.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Celebrity Insider &raquo; Comments Feed" href="https://celebrityinsider.org/comments/feed/" />
<meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /><meta name="format-detection" content="telephone=no"> <script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/celebrityinsider.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://celebrityinsider.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='ftg-front-styles-css' href='https://celebrityinsider.org/wp-content/plugins/ci-featured-tags/css/front-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://celebrityinsider.org/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<style id='contact-form-7-inline-css' type='text/css'>
.wpcf7 .wpcf7-recaptcha iframe {margin-bottom: 0;}.wpcf7 .wpcf7-recaptcha[data-align="center"] > div {margin: 0 auto;}.wpcf7 .wpcf7-recaptcha[data-align="right"] > div {margin: 0 0 0 auto;}
</style>
<link rel='stylesheet' id='dashicons-css' href='https://celebrityinsider.org/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css' href='https://celebrityinsider.org/wp-content/plugins/post-views-counter/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='zilla-likes-css' href='https://celebrityinsider.org/wp-content/plugins/zilla-likes/styles/zilla-likes.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-reset-css-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/reset.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-wordpress-css-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/wordpress.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-animation-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/animation.css' type='text/css' media='all' />
<link rel='stylesheet' id='ilightbox-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/ilightbox/ilightbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/jqueryui/custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/flexslider/flexslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='tooltipster-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/tooltipster.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-screen-css-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/screen.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-custom-menu-css-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/menu/left-fullwidth.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='griwpc-recaptcha-style-css' href='https://celebrityinsider.org/wp-content/plugins/recaptcha-in-wp-comments-form/css/recaptcha.css' type='text/css' media='all' />
<style id='griwpc-recaptcha-style-inline-css' type='text/css'>
.google-recaptcha-container{display:block;clear:both;}
</style>
<link rel='stylesheet' id='kirki_google_fonts-css' href='//fonts.googleapis.com/css?family=Roboto%3Aregular%2Citalic%2C700%2C%7CRaleway%3Aregular%2Citalic%2C700%2C900%2C700%2C400&#038;subset=all' type='text/css' media='all' />
<link rel='stylesheet' id='kirki-styles-global-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/modules/kirki/assets/css/kirki-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-script-responsive-css-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/grid.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-custom-menu-responsive-css-css' href='https://celebrityinsider.org/wp-content/themes/celebrityinsider/css/menu/left-fullwidth-grid.css' type='text/css' media='all' />
<link rel='stylesheet' id='grandnews-script-custom-css-css' href='https://celebrityinsider.org/wp-admin/admin-ajax.php?action=grandnews_custom_css' type='text/css' media='all' />
<script type='text/javascript' src='https://celebrityinsider.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/plugins/ci-featured-tags/js/front-ui.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var zilla_likes = {"ajaxurl":"https:\/\/celebrityinsider.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/plugins/zilla-likes/scripts/zilla-likes.js'></script>
<link rel='https://api.w.org/' href='https://celebrityinsider.org/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://celebrityinsider.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcelebrityinsider.org%2Frihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://celebrityinsider.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcelebrityinsider.org%2Frihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479%2F&#038;format=xml" />
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> <style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://celebrityinsider.org");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e03a11e8-f388-4f50-bb46-fd8b98d4c553';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://celebrityinsider.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.186ea02a-f890-410a-b109-aa22c180382d";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Celebrity Insider';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'THE LATEST CELEBRITY NEWS';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Celebrity Insider';
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = 'THE LATEST CELEBRITY NEWS';
oneSignal_options['promptOptions']['siteName'] = 'https://celebrityinsider.org';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['offset'] = {};
oneSignal_options['notifyButton']['offset']['bottom'] = '75px';
oneSignal_options['notifyButton']['offset']['left'] = '10px';
oneSignal_options['notifyButton']['offset']['right'] = '10px';
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="icon" href="https://celebrityinsider.org/wp-content/uploads/2016/08/cropped-favincon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://celebrityinsider.org/wp-content/uploads/2016/08/cropped-favincon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://celebrityinsider.org/wp-content/uploads/2016/08/cropped-favincon-180x180.png" />
<meta name="msapplication-TileImage" content="https://celebrityinsider.org/wp-content/uploads/2016/08/cropped-favincon-270x270.png" />

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-87019441-1', 'auto');
  ga('send', 'pageview');
</script>


<meta name="theme-color" content="#dedede">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8577613725353191",
    enable_page_level_ads: true,
    overlays: {bottom: true}
  });
</script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N3HRBGZ');</script>

<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "Article",
  "headline": "Rihanna Will Drop Her New Album Tentatively Called &amp;#8216;R9&amp;#8217; Sooner Than Planned For This Reason",

  "articleSection":"Entertainment",
  "datePublished": "2020-04-07T09:23:59-07:00",
  "dateModified": "2020-04-07T08:20:24-07:00",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"
  },

  "author": {
    "@type": "Person",
    "name": "Dylan Fisher"
  },


"image": {
    "@type": "ImageObject",
    "url": "https://celebrityinsider.org/wp-content/uploads/2020/04/Rihanna-New-Album-Coming-Soon.jpg",
    "height":1299,
    "width": 1800 
  },


   "publisher": {
    "@type": "Organization",
    "name": "Celebrity Insider",
    "url" : "https://celebrityinsider.org",
    "logo": {
      "@type": "ImageObject",
      "url": "https://celebrityinsider.org/wp-content/uploads/2017/05/Celebrity_Insider.jpg",
      "width": 600,
      "height": 60
    }
  },

  "description": "The people, who have been hounding Rihanna for a new album, might get their wish sooner than later. The diva recently revealed that she had been aggressively working on new music that she plans to release this year. The fashion"

}
</script>


<script>
        if ('serviceWorker' in navigator) {
						
            /* UNREGISTER service worker */
            navigator.serviceWorker.register('/service-worker.js').then(function(registration) {
                // registration worked
                console.log('Registration succeeded.');
                registration.unregister().then(function(boolean) {
                    console.log('Unregister service-worker', boolean);
                    // if boolean = true, unregister is successful
                });
            }).catch(function(error) {
                // registration failed
                console.log('Registration failed with ' + error);
            });
        }
    </script>


</head>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason","articleSection":"Entertainment","publisher":{"@type":"Organization","name":"Celebrity Insider","sameAs":["https:\/\/www.facebook.com\/CelebInsider\/","https:\/\/twitter.com\/CelebInsiderorg","https:\/\/pinterest.com\/celebinsider\/","https:\/\/plus.google.com\/111123435852741909455","https:\/\/www.instagram.com\/celebrityinsidernews\/"],"url":"https:\/\/celebrityinsider.org","logo":{"@type":"ImageObject","url":"https:\/\/celebrityinsider.org\/wp-content\/uploads\/2017\/05\/Celebrity_Insider.jpg","height":60,"width":600}},"alternativeHeadline":"Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason","description":"The people, who have been hounding Rihanna for a new album, might get their wish sooner than later. The diva recently revealed that she had been aggressively working on new music that she plans to...","inLanguage":"en-US","datePublished":"2020-04-07T09:23:59-07:00","dateModified":"2020-04-07T08:20:24-07:00","author":{"@type":"Person","name":"Dylan Fisher","sameAs":["https:\/\/celebrityinsider.org\/author\/dylanfisher\/"]},"about":{"@type":"Person","name":"drake","sameAs":"https:\/\/celebrityinsider.org\/tag\/drake\/"},"articleBody":"The people, who have been hounding Rihanna for a new album, might get their wish sooner than later. The diva recently revealed that she had been aggressively working on new music that she plans to release this year.\r\n\r\nThe fashion mogul also made it clear that while her project might be reggae and dancehall oriented -- like in other departments in her life, she does not want to be placed in a box.\r\n\r\nShe explained: \"I don't want my albums to feel like themes. There are no rules. There's no format. There's just good music, and if I feel it, I'm putting it out. Oh no, that is happening.\" \r\n\r\nhttps:\/\/www.instagram.com\/p\/B-k5I8vHyAq\/\r\n\r\nThe Barbadian popstar went on to say: \"I feel like I have no boundaries. I've done everything \u2013 I've done all the hits, I've tried every genre \u2013 now I'm just, I'm wide open. I can make anything that I want.\" \r\n\r\nA source told <em>Hollywood Life<\/em> that because of the coronavirus pandemic, Rihanna has been forced to hit pause on other projects and can, therefore, focus on her music.\r\n\r\nThe person in the know said: \"Rihanna has over a hundred songs either fully recorded and produced, various beats and tons of lyrics and plenty of unfinished songs scattered around for consideration for her next album. It has been a struggle to get the right songs needed for a full and complete album to her liking and she knows that her fans are jonesing for more from her and now with the world, as it is, it is putting all her focus to get new music out there quicker than she anticipated.\"\r\n\r\nhttps:\/\/www.instagram.com\/p\/B-lSRO8HoEE\/\r\n\r\nThe family friend added: \"She was thinking of not having an album come out this year and just work with others and bring it out whenever she had time for it. But now she has all the time in the world, and she is really looking forward to release her album this year and have a lot of new music for everyone to hear. She is now very motivated to make it all happen due to the circumstances that have been going on with the corona outbreak.\"\r\n\r\nAre you eager to hear Rihanna's new album? Do you think she will work with frequent collaborator Drake on it?","image":{"@type":"ImageObject","url":"https:\/\/celebrityinsider.org\/wp-content\/uploads\/2020\/04\/Rihanna-New-Album-Coming-Soon.jpg","height":1299,"width":1800},"mainEntityOfPage":"https:\/\/celebrityinsider.org\/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479\/"}</script>
<body class="post-template-default single single-post postid-385479 single-format-standard left_fullwidth">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N3HRBGZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<input type="hidden" id="pp_enable_right_click" name="pp_enable_right_click" value="1" />
<input type="hidden" id="pp_enable_dragging" name="pp_enable_dragging" value="1" />
<input type="hidden" id="pp_image_path" name="pp_image_path" value="https://celebrityinsider.org/wp-content/themes/celebrityinsider/images/" />
<input type="hidden" id="pp_homepage_url" name="pp_homepage_url" value="https://celebrityinsider.org/" />
<input type="hidden" id="pp_ajax_search" name="pp_ajax_search" value="1" />
<input type="hidden" id="pp_fixed_menu" name="pp_fixed_menu" value="1" />
<input type="hidden" id="tg_sidebar_sticky" name="tg_sidebar_sticky" value="1" />
<input type="hidden" id="pp_topbar" name="pp_topbar" value="1" />
<input type="hidden" id="pp_page_title_img_blur" name="pp_page_title_img_blur" value="1" />
<input type="hidden" id="tg_blog_slider_layout" name="tg_blog_slider_layout" value="" />
<input type="hidden" id="pp_back" name="pp_back" value="Back" />
<input type="hidden" id="tg_lightbox_skin" name="tg_lightbox_skin" value="metro-black" />
<input type="hidden" id="tg_lightbox_thumbnails" name="tg_lightbox_thumbnails" value="horizontal" />
<input type="hidden" id="tg_lightbox_opacity" name="tg_lightbox_opacity" value="0.95" />
<input type="hidden" id="tg_enable_lazy" name="tg_enable_lazy" value="" />
<input type="hidden" id="pp_footer_style" name="pp_footer_style" value="-1" />

<a id="close_mobile_menu" href="javascript:;"></a>
<div class="mobile_menu_wrapper">
<a id="close_mobile_menu_button" href="javascript:;"><i class="fa fa-close"></i></a>
<div class="menu-main-menu-container"><ul id="mobile_main_menu" class="mobile_main_nav sidebar"><li id="menu-item-12402" class="catmenu menu-item menu-item-type-custom menu-item-object-custom menu-item-12402"><a href="https://celebrityinsider.org/news/">News</a></li>
<li id="menu-item-4514" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4514"><a href="https://celebrityinsider.org/entertainment/" data-cat="71">Entertainment</a></li>
<li id="menu-item-4048" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4048"><a href="https://celebrityinsider.org/lifestyle/" data-cat="45">Lifestyle</a></li>
<li id="menu-item-4051" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4051"><a href="https://celebrityinsider.org/hollywood/" data-cat="1">Hollywood</a></li>
<li id="menu-item-4050" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4050"><a href="https://celebrityinsider.org/music/" data-cat="48">Music</a></li>
<li id="menu-item-4045" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4045"><a href="https://celebrityinsider.org/fashion/" data-cat="46">Fashion</a></li>
<li id="menu-item-4053" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4053"><a href="https://celebrityinsider.org/tv-shows/" data-cat="50">TV Shows</a></li>
<li id="menu-item-4049" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4049"><a href="https://celebrityinsider.org/movies/" data-cat="49">Movies</a></li>
<li id="menu-item-4446" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4446"><a href="https://celebrityinsider.org/sports/" data-cat="69">Sports</a></li>
<li id="menu-item-4519" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4519"><a href="https://celebrityinsider.org/politics/" data-cat="72">Politics</a></li>
<li id="menu-item-4041" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4041"><a href="https://celebrityinsider.org/awards/" data-cat="51">Awards</a></li>
</ul></div>

<div class="page_content_wrapper">
<div class="sidebar_wrapper">
<div class="sidebar">
<div class="content">
<ul class="sidebar_widget">
</ul>
</div>
</div>
</div>
</div>

</div>


<div id="wrapper">
<div class="header_style_wrapper">

<div class="above_top_bar">
<div class="page_content_wrapper">
<div class="menu-top-menu-container"><ul id="top_menu" class="top_nav"><li id="menu-item-4242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-4242"><a href="https://celebrityinsider.org/">Home</a></li>
<li id="menu-item-4320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4320"><a href="https://celebrityinsider.org/about/">About</a></li>
<li id="menu-item-4321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4321"><a href="https://celebrityinsider.org/contact/">Contact</a></li>
</ul></div>
<div class="social_wrapper">
<ul>
<li class="facebook"><a href="https://www.facebook.com/CelebInsider/" rel="nofollow"><i class="fa fa-facebook"></i></a></li>
<li class="twitter"><a href="https://twitter.com/CelebInsiderorg" rel="nofollow"><i class="fa fa-twitter"></i></a></li>
<li class="youtube"><a title="Youtube" href="https://www.youtube.com/c/CelebrityInsiderNews" rel="nofollow"><i class="fa fa-youtube"></i></a></li>
<li class="tumblr"><a title="Tumblr" href="http://celebrityinsider.tumblr.com" rel="nofollow"><i class="fa fa-tumblr"></i></a></li>
</ul>
</div> </div>
</div>
<div class="top_bar">

<div id="logo_wrapper">
<div class="standard_wrapper">
<div id="logo_normal" class="logo_container">
<div class="logo_align">
<a id="custom_logo" class="logo_wrapper default" href="https://celebrityinsider.org/">
<img src="https://celebrityinsider.org/wp-content/uploads/2016/10/celebrity-insider.png" alt="Celebrity Insider" width="340" height="95" />
<div style="padding-top: 9px; color: #666; font-size: 14px; background-color: #ffffff; text-align: center;">latest celebrity news, rumors and insider reports</div>
</a>
</div>
</div>

<div class="ppb_ads pp_ads_global_before_menu" style="display: block;">
<div style="float: right;color:#ff3c36; font-weight: bold; font-size:16px; padding-top:10px;">FREE NEWSLETTER</div>
<div style="text-align: right; color:#444444; font-size:15px; padding-top:40px;">Sign up for the latest celebrity news delivered to your inbox daily</div>
<div style="text-align: right;">
<form style="text-align:right;padding-top: 10px;" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=celebrity-insider', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true">
<input style="height: 37px;font-size: 14px;" type="text" name="email" onfocus="if(this.value==' your email') this.value=''" onblur="if(this.value=='') this.value=' your email';" value=" your email"><input type="hidden" value="celebrity-insider" name="uri"><input type="hidden" name="loc" value="en_US">
<input type="submit" value="Sign Up" style=" height: 34px; font-size: 13px; padding-top: 5px;"></form> </div>
</div>
</div>
</div>
<div id="menu_wrapper">
<div id="nav_wrapper">
<div class="nav_wrapper_inner">
<div id="menu_border_wrapper">
<div class="menu-main-menu-container"><ul id="main_menu" class="nav"><li id="menu-item-12402" class="catmenu menu-item menu-item-type-custom menu-item-object-custom menu-item-12402"><a href="https://celebrityinsider.org/news/">News</a></li>
<li id="menu-item-4514" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4514"><a href="https://celebrityinsider.org/entertainment/" data-cat="71">Entertainment</a></li>
<li id="menu-item-4048" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4048"><a href="https://celebrityinsider.org/lifestyle/" data-cat="45">Lifestyle</a></li>
<li id="menu-item-4051" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4051"><a href="https://celebrityinsider.org/hollywood/" data-cat="1">Hollywood</a></li>
<li id="menu-item-4050" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4050"><a href="https://celebrityinsider.org/music/" data-cat="48">Music</a></li>
<li id="menu-item-4045" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4045"><a href="https://celebrityinsider.org/fashion/" data-cat="46">Fashion</a></li>
<li id="menu-item-4053" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4053"><a href="https://celebrityinsider.org/tv-shows/" data-cat="50">TV Shows</a></li>
<li id="menu-item-4049" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4049"><a href="https://celebrityinsider.org/movies/" data-cat="49">Movies</a></li>
<li id="menu-item-4446" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4446"><a href="https://celebrityinsider.org/sports/" data-cat="69">Sports</a></li>
<li id="menu-item-4519" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4519"><a href="https://celebrityinsider.org/politics/" data-cat="72">Politics</a></li>
<li id="menu-item-4041" class="catmenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4041"><a href="https://celebrityinsider.org/awards/" data-cat="51">Awards</a></li>
</ul></div> </div>

<div id="logo_right_button">

<a href="javascript:;" id="search_icon"><i class="fa fa-search"></i></a>

<a id="logo2" href="https://celebrityinsider.org">
<img src="https://celebrityinsider.org/wp-content/uploads/2016/10/celebrity-insider.png" alt="Celebrity Insider" height="40" width=160">
</a>

<a href="javascript:;" id="mobile_nav_icon"></a>

</div>

</div>
</div>

</div>
</div>
</div>

<div id="page_content_wrapper" class=""> <div class="category-featured-tags">
<div class="category-featured-tags-left-column">
<span class="category-featured-tags-title">
Trending
<i class="fa fa-caret-right" aria-hidden="true"></i>
<i class="fa fa-caret-right" aria-hidden="true"></i>
</span>
</div>
<div class="featured-tags-wrapper">
<div class="featured-tags-container featured-tags-flex-wrapper ">
<a href="https://celebrityinsider.org/tag/r-kelly/" class="featured-tag-link">
r. kelly </a>
<a href="https://celebrityinsider.org/tag/khloe-kardashian/" class="featured-tag-link">
khloe kardashian </a>
<a href="https://celebrityinsider.org/tag/andy-cohen/" class="featured-tag-link">
andy cohen </a>
<a href="https://celebrityinsider.org/tag/coronavirus/" class="featured-tag-link">
coronavirus </a>
<a href="https://celebrityinsider.org/tag/kim-kardashian/" class="featured-tag-link">
kim kardashian </a>
<a href="https://celebrityinsider.org/tag/lil-nas-x/" class="featured-tag-link">
lil nas x </a>
<a href="https://celebrityinsider.org/tag/nene-leakes/" class="featured-tag-link">
nene leakes </a>
<a href="https://celebrityinsider.org/tag/tanya-sam/" class="featured-tag-link">
tanya sam </a>
<a href="https://celebrityinsider.org/tag/emani-richardson/" class="featured-tag-link">
Emani Richardson </a>
<a href="https://celebrityinsider.org/tag/bruce-willis/" class="featured-tag-link">
bruce willis </a>
<a href="https://celebrityinsider.org/tag/kirk-frost/" class="featured-tag-link">
kirk frost </a>
<a href="https://celebrityinsider.org/tag/halle-berry/" class="featured-tag-link">
halle berry </a>
<a href="https://celebrityinsider.org/tag/michael-che/" class="featured-tag-link">
Michael Che </a>
<a href="https://celebrityinsider.org/tag/reginae-carter/" class="featured-tag-link">
reginae carter </a>
<a href="https://celebrityinsider.org/tag/drake/" class="featured-tag-link">
drake </a>
<a href="https://celebrityinsider.org/tag/david-adefeso/" class="featured-tag-link">
David Adefeso </a>
<a href="https://celebrityinsider.org/tag/chris-brown/" class="featured-tag-link">
chris brown </a>
<a href="https://celebrityinsider.org/tag/meghan-markle/" class="featured-tag-link">
meghan markle </a>
<a href="https://celebrityinsider.org/tag/gabrielle-union/" class="featured-tag-link">
Gabrielle Union </a>
<a href="https://celebrityinsider.org/tag/brooklyn-daly/" class="featured-tag-link">
 brooklyn daly </a>
<a href="https://celebrityinsider.org/tag/eva-marcille/" class="featured-tag-link">
Eva Marcille </a>
<a href="https://celebrityinsider.org/tag/toya-johnson/" class="featured-tag-link">
toya johnson </a>
<a href="https://celebrityinsider.org/tag/cynthia-bailey/" class="featured-tag-link">
cynthia bailey </a>
</div>
</div>
<div class="category-featured-tags-controls">
<i class="fa fa-chevron-up category-featured-tags-controls-prev" aria-hidden="true"></i>
<i class="fa fa-chevron-down category-featured-tags-controls-next" aria-hidden="true"></i>
</div>
</div>
<div class="inner">

<div class="inner_wrapper">
<div class="sidebar_content">

<div id="post-385479" class="post-385479 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-drake tag-rihanna">
<div class="post_wrapper">
<div class="post_content_wrapper">
<div class="post_header">
<div class="post_header_title">
<div class="post_info_cat">
<div class="breadcrumb"><a href="https://celebrityinsider.org">Home</a> » <a href="https://celebrityinsider.org/entertainment/">Entertainment</a> </div> </div>
<h1 class="entry-title">Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason</h1>
<div class="post_detail post_date">
<span class="post_info_author">
<a href="https://celebrityinsider.org/author/dylanfisher/">
<span class="gravatar"><img alt='' src='https://celebrityinsider.org/wp-content/uploads/2017/03/DylanFisher-60x60.jpg' srcset='https://celebrityinsider.org/wp-content/uploads/2017/03/DylanFisher-120x120.jpg 2x' class='avatar avatar-60 photo' height='60' width='60' /></span><span class="vcard author post-author"><span class="fn">Dylan Fisher</a></span></span>
</span>
<span class="post_info_date">
<span class="post-date updated">Apr 7, 2020 9:23 AM PDT</span>
</span>
</div>
<div class="post_detail post_comment">
<div style="float: right; padding-left: 5px;" class="fb-like" data-href="https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/" data-layout="button_count" data-action="like" data-size="small" data-show-faces="false" data-share="true"></div>
<div class="post_info_comment">
<a href="https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/#respond"><i class="fa fa-commenting"></i>0</a>
</div>
<div class="post_info_view">
<i class="fa fa-eye"></i>222&nbsp;Views </div>
<a href="#" class="zilla-likes" id="zilla-likes-385479" title="Like this"><span class="zilla-likes-count">0</span> <span class="zilla-likes-postfix"></span></a>
</div>
</div>
</div>
<div style="padding-bottom: 15px; color: #ff3c36; font-family: Raleway, Helvetica, Arial, sans-serif; font-size: 20px; font-weight: 900; letter-spacing: 0px; text-align: left;">
<a href="https://bit.ly/Celebrity-Insider" target="_blank" rel="nofollow">
<img width="150" height="35" alt="watch us on youtube" src="https://celebrityinsider.org/images/watch-us-on-youtube.png"></a>
<span style="padding-top: 4px; padding-bottom: 15px;color: #ff3c36;font-family: Raleway, Helvetica, Arial, sans-serif;font-size: 20px;font-weight: 900;letter-spacing: 0px;text-align: right;float: right;"> <a href="https://celebrityinsider.org/atx-tv-festival-goes-virtual-in-2020-amid-covid-19-concerns-385460/" rel="prev"><img width="150" height="27" alt="Next Article" src="https://celebrityinsider.org/images/next1.gif" /></a> </span></div>
<div class="google-news-link text-center">
<a title="Subscribe to our Google News" href="https://news.google.com/publications/CAAqBwgKMJr8hAsw0oSCAw?hl=en-US&gl=US&ceid=US:en" target="_blank" rel="nofollow">Subscribe to our Google News<span><svg version="1.1" x="0px" y="0px" viewBox="0 0 363 298.4" xml:space="preserve">
<path fill="currentColor" d="M162.8,135.6c7.8,7.8,7.8,20.5,0,28.3L34.1,292.5C21.5,305.1,0,296.2,0,278.4V21C0,3.2,21.5-5.7,34.1,6.9L162.8,135.6z
						 M357.2,134.6L228.5,5.9C215.9-6.7,194.4,2.2,194.4,20v257.3c0,17.8,21.5,26.7,34.1,14.1l128.7-128.7C365,155,365,142.4,357.2,134.6
						z" />
</svg></span></a>
</div>
<hr class="post_divider" /><br class="clear" />
<div class="social_share_button_wrapper">
<ul>
<li><a class="tooltip facebook_share" title="Share On Facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-facebook"></i>Share On Facebook</a></li>
<li><a class="tooltip twitter_share" title="Share On Twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?original_referer=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/&text=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-twitter"></i>Tweet It</a></li>
<li><a class="tooltip pinterest_share" title="Share On Pinterest" target="_blank" rel="nofollow" href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcelebrityinsider.org%2Frihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479%2F&media=https%3A%2F%2Fcelebrityinsider.org%2Fwp-content%2Fuploads%2F2020%2F04%2FRihanna-New-Album-Coming-Soon.jpg"><i class="fa fa-pinterest"></i></a></li>
<li><a class="tooltip reddit_share" title="Share On Reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/&title=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason"><i class="fa fa-reddit"></i></a></li>
<li><a class="tooltip linkedin_share" title="Share On Linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&ro=true&trk=EasySocialShareButtons&title=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-linkedin"></i></a></li>
<li><a class="tooltip tumblr_share" title="Share On Tumblr" target="_blank" rel="nofollow" href="https://tumblr.com/share?s=&amp;v=3&amp;t=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&u=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-tumblr"></i></a></li>
</ul>
</div>
<Br class="clear" />
<div class="post_img static">
<img width="1800" height="1299" src="https://celebrityinsider.org/wp-content/uploads/2020/04/Rihanna-New-Album-Coming-Soon.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Rihanna New Album Coming Soon" />
<span class="media-credit" style="width: 100%;font-size: 10px;line-height: 1.2em;text-align: right;display: block;color: #909090;">Credit: Instagram</span>
</div>
<div class="post_header single">
<p>The people, who have been hounding Rihanna for a new album, might get their wish sooner than later. The diva recently revealed that she had been aggressively working on new music that she plans to release this year.</p>
<p>The fashion mogul also made it clear that while her project might be reggae and dancehall oriented &#8212; like in other departments in her life, she does not want to be placed in a box.</p>
<p>She explained: &#8220;I don&#8217;t want my albums to feel like themes. There are no rules. There&#8217;s no format. There&#8217;s just good music, and if I feel it, I&#8217;m putting it out. Oh no, that is happening.&#8221; </p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B-k5I8vHyAq/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/B-k5I8vHyAq/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank" rel="nofollow"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B-k5I8vHyAq/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank" rel="nofollow">new drop @fenty &#8230;. faux leather. and yes it’s as soft as everyone says. 💋</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/badgalriri/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank" rel="nofollow"> badgalriri</a> (@badgalriri) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-04-04T22:54:38+00:00">Apr 4, 2020 at 3:54pm PDT</time></p>
</div>
</blockquote>
<p><script async src="//www.instagram.com/embed.js"></script></p>
<p>The Barbadian popstar went on to say: &#8220;I feel like I have no boundaries. I&#8217;ve done everything – I&#8217;ve done all the hits, I&#8217;ve tried every genre – now I&#8217;m just, I&#8217;m wide open. I can make anything that I want.&#8221; </p>
<p>A source told <em>Hollywood Life</em> that because of the coronavirus pandemic, Rihanna has been forced to hit pause on other projects and can, therefore, focus on her music.</p>
<p>The person in the know said: &#8220;Rihanna has over a hundred songs either fully recorded and produced, various beats and tons of lyrics and plenty of unfinished songs scattered around for consideration for her next album. It has been a struggle to get the right songs needed for a full and complete album to her liking and she knows that her fans are jonesing for more from her and now with the world, as it is, it is putting all her focus to get new music out there quicker than she anticipated.&#8221;</p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B-lSRO8HoEE/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:500px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/B-lSRO8HoEE/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank" rel="nofollow"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B-lSRO8HoEE/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank" rel="nofollow">&#8230;<span class="__cf_email__" data-cfemail="e6c8a6808388929f">[email&#160;protected]</span></a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/badgalriri/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank" rel="nofollow"> badgalriri</a> (@badgalriri) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-04-05T02:34:13+00:00">Apr 4, 2020 at 7:34pm PDT</time></p>
</div>
</blockquote>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//www.instagram.com/embed.js"></script></p>
<p>The family friend added: &#8220;She was thinking of not having an album come out this year and just work with others and bring it out whenever she had time for it. But now she has all the time in the world, and she is really looking forward to release her album this year and have a lot of new music for everyone to hear. She is now very motivated to make it all happen due to the circumstances that have been going on with the corona outbreak.&#8221;</p><div style="text-align: center; padding-bottom: 15px;"><div style="text-align: center; padding-top: 25px; padding-bottom: 25px;">
<div style="text-align: center; color:#CCC; font-size:10px;">Advertisement</div>
<style type="text/css">
.adslot55 { width: 320px; height: 270px; }
@media (min-width:350px) { .adslot55 { width: 336px; height: 280px; } }
</style>
<ins class="adsbygoogle adslot55" style="display:inline-block;" data-ad-client="ca-pub-8577613725353191" data-ad-slot="4040837867"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div></div>
<p>Are you eager to hear Rihanna&#8217;s new album? Do you think she will work with frequent collaborator Drake on it?</p>
</p><div class="post-views post-385479 entry-meta">
<span class="post-views-icon dashicons dashicons-chart-bar"></span>
<span class="post-views-label">Post Views: </span>
<span class="post-views-count">222</span>
</div> <div class="google-news-link">
<a title="Subscribe to our Google News" href="https://news.google.com/publications/CAAqBwgKMJr8hAsw0oSCAw?hl=en-US&gl=US&ceid=US:en" target="_blank" rel="nofollow">Subscribe to our Google News<span><svg version="1.1" x="0px" y="0px" viewBox="0 0 363 298.4" xml:space="preserve">
<path fill="currentColor" d="M162.8,135.6c7.8,7.8,7.8,20.5,0,28.3L34.1,292.5C21.5,305.1,0,296.2,0,278.4V21C0,3.2,21.5-5.7,34.1,6.9L162.8,135.6z
							 M357.2,134.6L228.5,5.9C215.9-6.7,194.4,2.2,194.4,20v257.3c0,17.8,21.5,26.7,34.1,14.1l128.7-128.7C365,155,365,142.4,357.2,134.6
							z" />
</svg></span></a>
</div>
<div class="post_share_center">
<div class="social_share_button_wrapper">
<ul>
<li><a class="tooltip facebook_share" title="Share On Facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-facebook"></i>Share On Facebook</a></li>
<li><a class="tooltip twitter_share" title="Share On Twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?original_referer=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/&text=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-twitter"></i>Tweet It</a></li>
<li><a class="tooltip pinterest_share" title="Share On Pinterest" target="_blank" rel="nofollow" href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcelebrityinsider.org%2Frihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479%2F&media=https%3A%2F%2Fcelebrityinsider.org%2Fwp-content%2Fuploads%2F2020%2F04%2FRihanna-New-Album-Coming-Soon.jpg"><i class="fa fa-pinterest"></i></a></li>
<li><a class="tooltip reddit_share" title="Share On Reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/&title=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason"><i class="fa fa-reddit"></i></a></li>
<li><a class="tooltip linkedin_share" title="Share On Linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&ro=true&trk=EasySocialShareButtons&title=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-linkedin"></i></a></li>
<li><a class="tooltip tumblr_share" title="Share On Tumblr" target="_blank" rel="nofollow" href="https://tumblr.com/share?s=&amp;v=3&amp;t=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&u=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-tumblr"></i></a></li>
</ul>
</div>
<Br class="clear" /> </div>
<div style="padding-bottom: 15px; color: #ff3c36; font-family: Raleway, Helvetica, Arial, sans-serif; font-size: 20px; font-weight: 900; letter-spacing: 0px; text-align: left;">
<a href="https://bit.ly/Celebrity-Insider" rel="nofollow" target="_blank">
<img width="150" height="35" alt="watch us on youtube" src="https://celebrityinsider.org/images/watch-us-on-youtube.png"></a>
<span style="padding-top: 4px; padding-bottom: 15px;color: #ff3c36;font-family: Raleway, Helvetica, Arial, sans-serif;font-size: 20px;font-weight: 900;letter-spacing: 0px;text-align: right;float: right;"> <a href="https://celebrityinsider.org/atx-tv-festival-goes-virtual-in-2020-amid-covid-19-concerns-385460/" rel="prev"><img width="150" height="27" alt="Next Article" src="https://celebrityinsider.org/images/next1.gif" /></a> </span></div>
<hr />
</div>
<script type="text/javascript">
			window.twttr = (function (d,s,id) {
			    var t, js, fjs = d.getElementsByTagName(s)[0];
			    if (d.getElementById(id)) return; js=d.createElement(s); js.id=id;
			    js.src="https://platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
			    return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });
			    }(document, "script", "twitter-wjs"));
			</script>
<div class="post-featured-tags">
<span class="post-featured-tags-title">Read more about</span>
<a href="https://celebrityinsider.org/tag/drake/" class="featured-tag-link tag-featured">
drake </a>
<a href="https://celebrityinsider.org/tag/rihanna/" class="featured-tag-link tag-featured">
rihanna </a>
</div>
<br class="clear" />
<div style="text-align: center; color:#CCC; font-size:10px;">Advertisement</div>
<div style="text-align: center; padding-bottom:20px;">
<style type="text/css">
.adslot33 { width: 320px; height: 270px; }
@media (min-width:350px) { .adslot33 { width: 336px; height: 280px; } }
</style>
<ins class="adsbygoogle adslot33" style="display:inline-block;" data-ad-client="ca-pub-8577613725353191" data-ad-slot="3481441064"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="text/javascript">
	(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</br>
<h5 class="single_subtitle">You may also like</h5>
<div class="post_related">
<div class="one_third ">

<div id="post-385156" class="post-385156 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-chris-brown tag-rihanna">
<div class="post_wrapper grid_layout">
<div class="post_img small static">
<a href="https://celebrityinsider.org/rihanna-confesses-that-she-will-follow-in-the-footsteps-of-her-ex-boyfriends-chris-brown-had-this-reaction-385156/">
<img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Rihanna-Chris-Brown-Baby-Aeko-700x466.jpg" alt="" class="" style="width:700px;height:466px;" />
</a>
</div>
<div class="blog_grid_content">
<div class="post_header grid">
<strong><a href="https://celebrityinsider.org/rihanna-confesses-that-she-will-follow-in-the-footsteps-of-her-ex-boyfriends-chris-brown-had-this-reaction-385156/">Rihanna Confesses That She Will Follow In The Footsteps Of Her Ex-Boyfriends &#8212; Chris Brown Had This Reaction</a></strong>
<div class="post_attribute info_date">
Apr 5, 2020 11:15 PM PDT </div>
</div>
</div>
</div>
</div>

</div>
<div class="one_third ">

<div id="post-384526" class="post-384526 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-50-cent tag-drake tag-sophie-brussaux">
<div class="post_wrapper grid_layout">
<div class="post_img small static">
<a href="https://celebrityinsider.org/50-cent-shares-his-thoughts-on-drakes-son-adonis-with-these-photos-some-say-he-is-throwing-shade-but-porsha-williams-thinks-otherwise-384526/">
<img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Drake-Adonis-Brussaux-50-Cent-Porsha-Williams-700x466.jpg" alt="" class="" style="width:700px;height:466px;" />
</a>
</div>
<div class="blog_grid_content">
<div class="post_header grid">
<strong><a href="https://celebrityinsider.org/50-cent-shares-his-thoughts-on-drakes-son-adonis-with-these-photos-some-say-he-is-throwing-shade-but-porsha-williams-thinks-otherwise-384526/">50 Cent Shares His Thoughts On Drake&#8217;s Son, Adonis, With These Photos &#8212; Some Say He Is Throwing Shade, But Porsha Williams Thinks Otherwise</a></strong>
<div class="post_attribute info_date">
Apr 4, 2020 5:25 AM PDT </div>
</div>
</div>
</div>
</div>

</div>
<div class="one_third last">

<div id="post-383912" class="post-383912 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment tag-chris-brown tag-rihanna">
<div class="post_wrapper grid_layout">
<div class="post_img small static">
<a href="https://celebrityinsider.org/rihanna-opens-up-about-wanting-children-and-chris-brown-reportedly-responds-383912/">
<img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Chris-Brown-and-Rihanna-2-700x466.jpg" alt="" class="" style="width:700px;height:466px;" />
</a>
</div>
<div class="blog_grid_content">
<div class="post_header grid">
<strong><a href="https://celebrityinsider.org/rihanna-opens-up-about-wanting-children-and-chris-brown-reportedly-responds-383912/">Rihanna Opens Up About Wanting Children And Chris Brown Reportedly Responds</a></strong>
<div class="post_attribute info_date">
Apr 2, 2020 3:45 AM PDT </div>
</div>
</div>
</div>
</div>

</div>
<div>&nbsp;</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-8577613725353191" data-ad-slot="8735192804"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="read_next_wrapper">
<div class="post_img next_post">
<a href="https://celebrityinsider.org/toya-johnsons-baby-girl-reigny-rushing-is-the-sweetest-kid-while-stuffing-her-face-with-ice-cream-see-the-video-385447/"><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Reign-Rushing-Toya-Wright-Johnson-700x466.jpg" alt="Toya Johnson&#039;s Baby Girl, Reigny Rushing Is The Sweetest Kid While Stuffing Her Face With Ice Cream - See The Video" /></a>
</div>
<div class="post_content">
<div class="read_next_label"><a href="https://celebrityinsider.org/toya-johnsons-baby-girl-reigny-rushing-is-the-sweetest-kid-while-stuffing-her-face-with-ice-cream-see-the-video-385447/">Read Next</a></div>
<div class="next_post_title">
<h3><a href="https://celebrityinsider.org/toya-johnsons-baby-girl-reigny-rushing-is-the-sweetest-kid-while-stuffing-her-face-with-ice-cream-see-the-video-385447/">Toya Johnson&#039;s Baby Girl, Reigny Rushing Is The Sweetest Kid While Stuffing Her Face With Ice Cream - See The Video</a></h3>
</div>
</div>
<br class="clear" />
<div class="adstext" style="text-align: center; color:#CCC; font-size:10px; padding-top:30px;">Advertisement</div>
<div style="text-align: center; padding-bottom:10px;">
<style type="text/css">
.adslot22 { display:inline-block; min-width:250px; max-width:767px; width:100%; min-height:350px; max-height:400px; height:100%; }
@media (min-width: 767px) { .adslot22 { display: none; } }
</style>
<ins class="adsbygoogle adslot22" data-ad-client="ca-pub-8577613725353191" data-ad-slot="1796750263" < ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
</div>
</div>
</div>

<div class="fullwidth_comment_wrapper sidebar">
<h5 class="single_subtitle">Leave A Reply</h5><br class="clear" />
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://celebrityinsider.org/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input placeholder="Name*" id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input type="email" placeholder="Email*" id="email" name="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p id="griwpc-container-id" class="google-recaptcha-container recaptcha-align-left"><span id="griwpc-widget-id" class="g-recaptcha" data-forced="0"></span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='385479' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="180775deca" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="135" /></p></form> </div>
<br />
</div>
</div>
<div class="sidebar_wrapper" data-sticky>
<div data-sticky-content>
<div class="sidebar_top"></div>
<div class="sidebar">
<div class="content">
<ul class="sidebar_widget">
<li id="text-14" class="widget widget_text"><h2 class="widgettitle"><span>Follow Us</span></h2>
<div class="textwidget"><center>
<a href="https://www.facebook.com/CelebInsider/" class="shareicons" target="_blank" style="margin-right: 5px;" rel="noopener noreferrer"><img src="https://celebrityinsider.org/images/socf.png" alt="Follow Us on Facebook" height="42" width="42"></a>
<a href="https://twitter.com/CelebInsiderorg" target="_blank" style="margin-right: 5px;" rel="noopener noreferrer"><img src="https://celebrityinsider.org/images/soct.png" alt="Follow Us on Twitter" height="42" width="42"></a>
<a href="https://flipboard.com/@celebrityinside/celebrity-news-fuas4270z" target="_blank" style="margin-right: 5px;" rel="noopener noreferrer"><img src="https://celebrityinsider.org/images/socflip.png" alt="Follow Us on Flipboard" height="42" width="42"></a>
<a href="https://celebrityinsider.org/feed/" target="_blank" style="margin-right: 5px;" rel="noopener noreferrer"><img src="https://celebrityinsider.org/images/rss.png" alt="Our RSS" height="42" width="42"></a>
<a href="https://celebrityinsider.tumblr.com/" target="_blank" rel="noopener noreferrer"><img src="https://celebrityinsider.org/images/soctu.png" alt="Follow Us on Tumblr" height="42" width="42"></a>
</center></div>
</li>
<li id="text-16" class="widget widget_text"> <div class="textwidget"><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=1678766745783251";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div align="center"><div class="fb-page" data-href="https://www.facebook.com/CelebInsider/" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/CelebInsider/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/CelebInsider/">Celebrity Insider</a></blockquote></div>
</div></div>
</li>
<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="text-align: center">
<script src="https://apis.google.com/js/platform.js"></script>
<div class="g-ytsubscribe" data-channelid="UCZHJM8iY_38C48fpide8rlA" data-layout="full" data-count="hidden"></div>
</div></div></li>
<li id="grand_news_recent_posts-6" class="widget Grand_News_Recent_Posts"><h2 class="widgettitle"><span>Recent Posts</span></h2><ul class="posts blog withthumb "><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/cindy-crawford-says-she-was-asked-to-remove-her-iconic-beauty-mark-if-she-wanted-to-make-it-as-a-model-385659/" title="Cindy Crawford Says She Was Asked To Remove Her Iconic Beauty Mark If She Wanted To Make It As A Model!"><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/cindy-crawford-300x200.jpg" class="tg-lazy" alt="Cindy Crawford Says She Was Asked To Remove Her Iconic Beauty Mark If She Wanted To Make It As A Model!" /></a></div><h6><a href="https://celebrityinsider.org/cindy-crawford-says-she-was-asked-to-remove-her-iconic-beauty-mark-if-she-wanted-to-make-it-as-a-model-385659/" title="Cindy Crawford Says She Was Asked To Remove Her Iconic Beauty Mark If She Wanted To Make It As A Model!">Cindy Crawford Says She Was Asked To Remove Her Iconic Beauty Mark If She Wanted To Make It As A Model!</a></h6></li><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/katy-perry-and-orlando-bloom-keeping-the-pregnant-singer-healthy-while-in-quarantine-heres-how-385657/" title="Katy Perry And Orlando Bloom Keeping The Pregnant Singer Healthy While In Quarantine - Here's How!"><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Katy-Perry-orlando-bloom-300x200.jpg" class="tg-lazy" alt="Katy Perry And Orlando Bloom Keeping The Pregnant Singer Healthy While In Quarantine - Here's How!" /></a></div><h6><a href="https://celebrityinsider.org/katy-perry-and-orlando-bloom-keeping-the-pregnant-singer-healthy-while-in-quarantine-heres-how-385657/" title="Katy Perry And Orlando Bloom Keeping The Pregnant Singer Healthy While In Quarantine - Here's How!">Katy Perry And Orlando Bloom Keeping The Pregnant Singer Healthy While In Quarantine - Here's How!</a></h6></li><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/rosie-odonnell-says-she-has-no-intention-of-returning-to-the-view-as-long-as-whoopi-goldberg-in-still-on-the-panel-385656/" title="Rosie O’Donnell Says She Has No Intention Of Returning To 'The View' As Long As Whoopi Goldberg In Still On The Panel!"><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Whoopi-Goldberg-rosie-odonnell-300x161.jpg" class="tg-lazy" alt="Rosie O’Donnell Says She Has No Intention Of Returning To 'The View' As Long As Whoopi Goldberg In Still On The Panel!" /></a></div><h6><a href="https://celebrityinsider.org/rosie-odonnell-says-she-has-no-intention-of-returning-to-the-view-as-long-as-whoopi-goldberg-in-still-on-the-panel-385656/" title="Rosie O’Donnell Says She Has No Intention Of Returning To 'The View' As Long As Whoopi Goldberg In Still On The Panel!">Rosie O’Donnell Says She Has No Intention Of Returning To 'The View' As Long As Whoopi Goldberg In Still On The Panel!</a></h6></li><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/r-kellys-plea-to-be-let-out-of-prison-due-to-covid-19-is-rejected-by-the-judge-385581/" title="R. Kelly's Plea To Be Let Out Of Prison Due To COVID-19 Is Rejected By The Judge"><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/R.-Kelly-Slate.com_-300x214.jpeg" class="tg-lazy" alt="R. Kelly's Plea To Be Let Out Of Prison Due To COVID-19 Is Rejected By The Judge" /></a></div><h6><a href="https://celebrityinsider.org/r-kellys-plea-to-be-let-out-of-prison-due-to-covid-19-is-rejected-by-the-judge-385581/" title="R. Kelly's Plea To Be Let Out Of Prison Due To COVID-19 Is Rejected By The Judge">R. Kelly's Plea To Be Let Out Of Prison Due To COVID-19 Is Rejected By The Judge</a></h6></li></ul></li>
<li id="text-36" class="widget widget_text"> <div class="textwidget"><div class="ads1" style="text-align: center; color:#CCC; font-size:10px; padding-top: 20px;">Advertisement</div>
<div style="text-align: center;">
<style type="text/css">
.adslot { display:inline-block; width: 100%; height: 100%}
@media (max-width: 767px) { .adslot { display: none; } }
</style>
<ins class="adsbygoogle adslot" data-ad-client="ca-pub-8577613725353191" data-ad-slot="8561638669" data-ad-format="vertical"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div></div>
</li>
<li id="recent-comments-8" class="widget widget_recent_comments"><h2 class="widgettitle"><span>RECENT COMMENTS</span></h2>
<ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Kimberly</span> on <a href="https://celebrityinsider.org/rasheeda-frost-finally-tells-her-truth-about-reports-she-married-husband-kirk-frost-when-she-was-17-years-old-some-love-hip-hop-atlanta-fans-have-trouble-with-the-answer-385510/comment-page-1/#comment-121199" title="Rasheeda Frost Finally Tells Her Truth About Reports She Married Husband Kirk Frost When She Was 17 Years Old &#8212; Some &#8216;Love &#038; Hip Hop: Atlanta&#8217; Fans Have Trouble With The Answer">Rasheeda Frost Finally Tells Her Truth About Reports She Married Husband Kirk Frost When She Was 17 Years Old &#8212; Some &#8216;Love &#038; Hip Hop: Atlanta&#8217; Fans Have Trouble With The Answer</a></li><li class="recentcomments"><span class="comment-author-link">Idele Dawson</span> on <a href="https://celebrityinsider.org/savage-kenya-moore-shares-some-steamy-clips-on-social-media-that-have-fans-saying-that-she-deserves-someone-better-than-marc-daly-385247/comment-page-1/#comment-121198" title="Savage Kenya Moore Shares Some Steamy Clips On Social Media That Have Fans Saying That She Deserves Someone Better Than Marc Daly">Savage Kenya Moore Shares Some Steamy Clips On Social Media That Have Fans Saying That She Deserves Someone Better Than Marc Daly</a></li><li class="recentcomments"><span class="comment-author-link">Colette</span> on <a href="https://celebrityinsider.org/r-kelly-lands-in-more-trouble-after-new-videos-are-found-by-authorities-383581/comment-page-1/#comment-121197" title="R. Kelly Lands In More Trouble After New Videos Are Found By Authorities">R. Kelly Lands In More Trouble After New Videos Are Found By Authorities</a></li><li class="recentcomments"><span class="comment-author-link">Deb</span> on <a href="https://celebrityinsider.org/savage-kenya-moore-shares-some-steamy-clips-on-social-media-that-have-fans-saying-that-she-deserves-someone-better-than-marc-daly-385247/comment-page-1/#comment-121195" title="Savage Kenya Moore Shares Some Steamy Clips On Social Media That Have Fans Saying That She Deserves Someone Better Than Marc Daly">Savage Kenya Moore Shares Some Steamy Clips On Social Media That Have Fans Saying That She Deserves Someone Better Than Marc Daly</a></li></ul></li>
<li id="grand_news_popular_posts-15" class="widget Grand_News_Popular_Posts"><h2 class="widgettitle"><span>Popular Posts</span></h2><ul class="posts blog withthumb "><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/rihanna-confesses-that-she-will-follow-in-the-footsteps-of-her-ex-boyfriends-chris-brown-had-this-reaction-385156/" title="Rihanna Confesses That She Will Follow In The Footsteps Of Her Ex-Boyfriends -- Chris Brown Had This Reaction"><div class="post_number">1</div><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Rihanna-Chris-Brown-Baby-Aeko-300x200.jpg" class="tg-lazy" alt="Rihanna Confesses That She Will Follow In The Footsteps Of Her Ex-Boyfriends -- Chris Brown Had This Reaction" /></a></div><h6><a href="https://celebrityinsider.org/rihanna-confesses-that-she-will-follow-in-the-footsteps-of-her-ex-boyfriends-chris-brown-had-this-reaction-385156/" title="Rihanna Confesses That She Will Follow In The Footsteps Of Her Ex-Boyfriends -- Chris Brown Had This Reaction">Rihanna Confesses That She Will Follow In The Footsteps Of Her Ex-Boyfriends -- Chris Brown Had This Reaction</a></h6></li><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/remy-ma-worked-for-hours-planning-a-surprise-party-for-her-daughter-who-shamed-her-in-this-viral-video-papooses-wife-impressed-fans-with-her-talents-383578/" title="Remy Ma Worked For Hours Planning A Surprise Party For Her Daughter Who Shamed Her In This Viral Video --  Papoose's Wife Impressed Fans With Her Talents"><div class="post_number">2</div><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Remy-Ma-Papoose-Quarantine-Party-For-Daughter-300x245.jpg" class="tg-lazy" alt="Remy Ma Worked For Hours Planning A Surprise Party For Her Daughter Who Shamed Her In This Viral Video --  Papoose's Wife Impressed Fans With Her Talents" /></a></div><h6><a href="https://celebrityinsider.org/remy-ma-worked-for-hours-planning-a-surprise-party-for-her-daughter-who-shamed-her-in-this-viral-video-papooses-wife-impressed-fans-with-her-talents-383578/" title="Remy Ma Worked For Hours Planning A Surprise Party For Her Daughter Who Shamed Her In This Viral Video --  Papoose's Wife Impressed Fans With Her Talents">Remy Ma Worked For Hours Planning A Surprise Party For Her Daughter Who Shamed Her In This Viral Video -- Papoose's Wife Impressed Fans With Her Talents</a></h6></li><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/chris-brown-lands-in-trouble-for-this-tiktok-video-that-he-did-with-a-famous-person-who-made-racist-comments-384550/" title="Chris Brown Lands In Trouble For This TikTok Video That He Did With A Famous Person Who Made Racist Comments"><div class="post_number">3</div><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Chris-Brown-Tyga-Austin-McBroom-Controversy-300x200.jpg" class="tg-lazy" alt="Chris Brown Lands In Trouble For This TikTok Video That He Did With A Famous Person Who Made Racist Comments" /></a></div><h6><a href="https://celebrityinsider.org/chris-brown-lands-in-trouble-for-this-tiktok-video-that-he-did-with-a-famous-person-who-made-racist-comments-384550/" title="Chris Brown Lands In Trouble For This TikTok Video That He Did With A Famous Person Who Made Racist Comments">Chris Brown Lands In Trouble For This TikTok Video That He Did With A Famous Person Who Made Racist Comments</a></h6></li><li><div class="post_circle_thumb"><a href="https://celebrityinsider.org/salma-hayek-does-yoga-in-cocktail-dress-and-heels-and-fans-are-confused-384474/" title="Salma Hayek Does Yoga In Cocktail Dress And Heels And Fans Are Confused"><div class="post_number">4</div><img src="https://celebrityinsider.org/wp-content/uploads/2020/04/Salma-Hayek-300x200.jpg" class="tg-lazy" alt="Salma Hayek Does Yoga In Cocktail Dress And Heels And Fans Are Confused" /></a></div><h6><a href="https://celebrityinsider.org/salma-hayek-does-yoga-in-cocktail-dress-and-heels-and-fans-are-confused-384474/" title="Salma Hayek Does Yoga In Cocktail Dress And Heels And Fans Are Confused">Salma Hayek Does Yoga In Cocktail Dress And Heels And Fans Are Confused</a></h6></li></ul></li>
</ul>
</div>
</div>
<br class="clear" />
<div class="sidebar_bottom"></div>
</div>
</div>
</div>

</div>
</div>
<div align="center">
</div>
<div class="footer_bar   ">
<div class="footer_bar_wrapper ">
<div class="menu-footer-menu-container"><ul id="footer_menu" class="footer_nav"><li id="menu-item-4428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-4428"><a href="https://celebrityinsider.org/">Home</a></li>
<li id="menu-item-4080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4080"><a href="https://celebrityinsider.org/about/">About</a></li>
<li id="menu-item-6507" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6507"><a href="https://celebrityinsider.org/link-to-content/">Link to Content</a></li>
<li id="menu-item-4078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-4078"><a href="https://celebrityinsider.org/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-4077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4077"><a href="https://celebrityinsider.org/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-22275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22275"><a href="https://celebrityinsider.org/unsubscribe/">Unsubscribe</a></li>
<li id="menu-item-4075" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4075"><a href="https://celebrityinsider.org/sitemap/">Sitemap</a></li>
<li id="menu-item-124022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124022"><a href="https://celebrityinsider.org/feed/">RSS</a></li>
<li id="menu-item-4081" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4081"><a href="https://celebrityinsider.org/contact/">Contact</a></li>
</ul></div> <div id="copyright">© 2017-2019 <a href="https://celebrityinsider.org/" title="Celebrity Insider">Celebrity Insider</a>&trade;</div>
<a id="toTop"><i class="fa fa-angle-up"></i></a>
</div>
</div>
</div>
<div id="overlay_background">
<div id="fullscreen_share_wrapper">
<div class="fullscreen_share_content">
<div id="social_share_wrapper">
<ul>
<li><a class="tooltip" title="Share On Facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-facebook marginright"></i></a></li>
<li><a class="tooltip" title="Share On Twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?original_referer=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/&text=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-twitter marginright"></i></a></li>
<li><a class="tooltip" title="Share On Pinterest" target="_blank" rel="nofollow" href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fcelebrityinsider.org%2Frihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479%2F&media=https%3A%2F%2Fcelebrityinsider.org%2Fwp-content%2Fuploads%2F2020%2F04%2FRihanna-New-Album-Coming-Soon.jpg"><i class="fa fa-pinterest marginright"></i></a></li>
<li><a class="tooltip" title="Share On Google+" target="_blank" rel="nofollow" href="https://plus.google.com/share?url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-google-plus marginright"></i></a></li>
<li><a class="tooltip" title="Share On Reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/&title=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason"><i class="fa fa-reddit marginright"></i></a></li>
<li><a class="tooltip" title="Share On Tumblr" target="_blank" rel="nofollow" href="https://tumblr.com/share?s=&amp;v=3&amp;t=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&u=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-tumblr marginright"></i></a></li>
<li><a class="tooltip" title="Share On Linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&ro=true&trk=EasySocialShareButtons&title=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason&url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/"><i class="fa fa-linkedin marginright"></i></a></li>
<li><a class="tooltip" title="Share On delicious" target="_blank" rel="nofollow" href="https://delicious.com/save?v=5&amp;noui&amp;jump=close&amp;url=https://celebrityinsider.org/rihanna-will-drop-her-new-album-tentatively-called-r9-sooner-than-planned-for-this-reason-385479/&amp;title=Rihanna Will Drop Her New Album Tentatively Called &#8216;R9&#8217; Sooner Than Planned For This Reason"><i class="fa fa-delicious marginright"></i></a></li>
</ul>
</div> </div>
</div>
</div>
<div id="overlay_background_search">
<a id="search_close_button" class="tooltip" title="Close" href="javascript:;"><i class="fa fa-close"></i></a>
<div class="search_wrapper">
<div class="search_content">
<form role="search" method="get" name="searchform" id="searchform" action="https://celebrityinsider.org/">
<div>
<input type="text" value="" name="s" id="s" autocomplete="off" placeholder="Enter Keyword" />
<div class="search_tagline">Press enter/return to begin your search</div>
<button>
<i class="fa fa-search"></i>
</button>
</div>
<div id="autocomplete"></div>
</form>
</div>
</div>
</div>
<script type='text/javascript' src='https://celebrityinsider.org/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/celebrityinsider.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"js","requestURL":"https:\/\/celebrityinsider.org\/wp-admin\/admin-ajax.php","postID":"385479","nonce":"728c8a5582"};
/* ]]> */
</script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/plugins/post-views-counter/js/frontend.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/jquery.easing.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/jquery.sticky-kit.min.js?v=2.4'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/jquery.lazy.min.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/jquery.cookie.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/jquery.tooltipster.min.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/custom_plugins.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/themes/celebrityinsider/js/custom.js?v=1514134505'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var griwpco = {"ajax_url":"https:\/\/celebrityinsider.org\/wp-admin\/admin-ajax.php","standardQueries":"0","formID":"commentform","formQuery":"#respond form","formQueryElem":"0","buttonID":"submit","buttonQuery":"#respond *[type='submit']","buttonQueryElem":"0","recaptcha_elem":null,"recaptcha_id":"griwpc-widget-id","recaptcha_skey":"6LeOuBcUAAAAAEaWvAmoJ8QG1vpA5x4geuqgV_QA","recaptcha_theme":"light","recaptcha_size":"normal","recaptcha_type":"image","recaptcha_align":"left","recaptcha_otcm":"0","recaptcha_tag":"p","recaptcha_lang":"","allowCreditMode":"0","home_link_address":"http:\/\/www.joanmiquelviade.com\/plugin\/google-recaptcha-in-wp-comments-form\/","home_link_title":"reCAPTCHA plugin homepage","home_link_text":"Get reCAPTCHA plugin","version":"9.1.2","reCAPTCHAloaded":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/plugins/recaptcha-in-wp-comments-form/js/base.js'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-content/plugins/recaptcha-in-wp-comments-form/js/recaptcha.js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=griwpcOnloadCallback&#038;render=explicit'></script>
<script type='text/javascript' src='https://celebrityinsider.org/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?' async='async'></script>
<script async="async" type='text/javascript' src='https://celebrityinsider.org/wp-content/plugins/akismet/_inc/form.js'></script>
<script src="https://www.gstatic.com/firebasejs/3.6.6/firebase.js"></script>
<script>
  // Initialize Firebase
  var config = {
    apiKey: "AIzaSyAN-wM0ivFWomi3GvYna7ZDVRiqym3hiJY",
    authDomain: "celebrity-insider.firebaseapp.com",
    databaseURL: "https://celebrity-insider.firebaseio.com",
    storageBucket: "celebrity-insider.appspot.com",
    messagingSenderId: "104049217996"
  };
  firebase.initializeApp(config);
</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"9uhRo1IWhd10kU", domain:"celebrityinsider.org",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=9uhRo1IWhd10kU" style="display:none" height="1" width="1" alt="" /></noscript>

</body>
</html>
